OSPF 基础实验

一、环境准备

1. 软件:GNS3

2. 路由:c7200

二、实验操作

实验要求:

1、掌握多区域的 OSPF 配置方法。

2、区别不同区域的路由。

3、掌握 OSPF 的路由汇总配置。

4、掌握 OSPF 的基本配置命令。

5、掌握 OSPF 接口认证及区域认证的配置方法。

实验拓扑:

实验过程:

1、根据实验拓扑,对路由器各接口配置 IP 地址。

2、在各路由器上配置 OSPF 协议。

R1 上的配置清单:

R1(config)#router ospf 33                                  

R1(config-router)#net

R1(config-router)#network 192.33.4.0 0.0.0.255 area 1

R1(config-router)#network 192.33.5.0 0.0.0.255 area 1

R1(config-router)#network 192.33.1.0 0.0.0.255 area 0

R2 上的配置清单:

R2(config)#router ospf 33                                  

R2(config-router)#network 192.33.1.0 0.0.0.255 area 0

R2(config-router)#network 192.33.3.0 0.0.0.255 area 0

R2(config-router)#network 192.33.2.0 0.0.0.255 area 2

R3 上的配置清单:

R3(config)#router ospf 33                                 

R3(config-router)#network 192.33.2.0 0.0.0.255 area 2

R3(config-router)#network 172.33.0.0 0.0.0.255 area 2

R3(config-router)#network 172.33.1.0 0.0.0.255 area 2

 

问题 1:在 R2 上查看邻居信息,一共有几个邻居?邻居的路由 ID 是多少?

参考命令:

show ip ospf neighbor

答:一共有两个邻居,邻居ID为:192.33.4.1 、192.33.0.1 

问题 2:在 R3 上查看 OSPF 链路状态数据库,一共有几种链路状态,哪几种?

参考命令:

show ip ospf database

 答:共有三种链路状态:Router Link States、Net Link States、Summary Net Link States。

 

问题 3:在 R1 上查看路由表,有哪些是其他区域路由?

答:其他区域路由条目

O IA    172.33.1.0/24 [110/3] via 192.33.1.2, 02:41:47, FastEthernet0/0
O IA    172.33.0.1/32 [110/3] via 192.33.1.2, 02:41:47, FastEthernet0/0
O IA    192.33.2.0/24 [110/2] via 192.33.1.2, 02:41:47, FastEthernet0/0

3、区域汇总

在路由器 R1 中查看链路状态数据库,会发现有 2 条类型 3 的 LSA,我们可以在路由器 R2(ABR)上进行区域汇总,减少路由条目。

参考命令:

R2(config)#router ospf 33                                 

R2(config-router)#area 2 range 172.33.0.0 255.255.0.0

问题 4:在每个路由器上清空路由表,查看 R1 上路由表有什么变化?

答:172.33.0.1/24 和 172.33.1.1/24两个网络的路由条目汇总为一条路由条目。

初始R1路由:

改变R1路由:

同样我们可以在 R1 上对区域 1 的路由进行汇总,

参考命令:

R1(config-router)#area 1 range 192.33.4.0 255.255.254.0

问题 5:在每个路由器上清空路由表,查看 R3 上路由表有什么变化?

答:R3 路由器上对路由器R1上的Loopback 0接口的网络进行了汇总。

4、在 R1 和 R2 上启用接口认证

明文认证:

R1 上的参考命令:

R1(config)#int f0/0

R1(config-if)#ip ospf authentication

R1(config-if)#ip ospf authentication-key jtc              

问题 6:配置后等待若干秒,在 R1 上查看路由表,还能看到 R2 和 R3 上的路由吗?

答:在 R1 上查看路由表,不能看到 R2 和 R3 上的路由条目。

问题 7:参考 R1 的配置在 R2 的接口 f0/1 上配置认证,配置后等若干秒,在 R1 上能看到其他路由器上的路由吗?

答:在 R1 上查看路由表,能看到 R2 和 R3 上的路由条目。

5、密文认证:在 R2 和 R3 的接口上配置密文,参考下列命令配置密文认证,检查结果。

R2 上的参考命令:

R2(config)#interface f0/0

R2(config-if)#ip ospf authentication message-digest

R2(config-if)#ip ospf message-digest-key 1 md5 jtc              

在 R3 的 f0/1 接口上参考 R1 的配置进行配置。

 

人已赞赏
随笔日记

gitbook 入门教程之使用 gitbook.com 在线开发电子书

2020-11-9 4:12:35

随笔日记

[原]Veracrypt使用Yubikey作为安全令牌

2020-11-9 4:12:37

0 条回复 A文章作者 M管理员
    暂无讨论,说说你的看法吧
个人中心
购物车
优惠劵
今日签到
有新私信 私信列表
搜索