先看效果     网站地址:www.yunss.cc

效果图

QQ截图20160224142417.png

前端和后端先安装哪个,都可以的!

我是先安装的前端,和安装网站是一模一样的。只不过失败是因为对环境要求比较高!

PHP必须是5.4  版本以上的 ,mysql也要求是5.4以上版本。

不然前端肯定是空白页面

我是单独注册了一个虚拟主机,把前端搭建到虚拟主机里面。数据库用的VPS搭建的远程连接


1.前端安装

只要配置的环境能够达到要求,直接上传源代码就行了。

然后导入数据库

前端只能使用2.5版本的!  3.0以后的有变动,没试过!

现在大部分都是低于2.5版本的前端,找了很多教程。写的都是2.5文件相符合,如果你按照3.0操作。文件夹你根本就找不到

2.后端安装

后端安装可以按照下面两个教程的任意一个

祥磊部落:https://www.bxl.me/8896.html

厘米天空:http://www.cmsky.com

安装后台需要注意

无法安装pip install cymysql

可以按照下面这个教程

祥磊部落:https://www.bxl.me/8822.html

如果启动python server.py不成功

可能是没进入shadowsocks文件夹下面进行命令

需要如下两个命令

cd shadowsocks/shadowsockspython server.py

最后如果添加节点以后出现500无法登陆,应该是防火墙的问题。可以暂时停止防火墙重新测试

service iptables stop

重新开启防火墙命令

service iptables restart

如果确认是防火墙的问题,可以在防火墙设置端口。


加密方式

默认的是RC4-MD5,在shadow socks文件夹下有个config.json可以修改!不然也会出错的


下面的是我安装的时候参考的相关教程

1、http://www.dou-bi.com/ss-jc14/

2、http://138.128.200.24/default/8.html

3、http://ilazycat.com/posts/2015/03/config-shadowsocks-manyuser-sspanel.html/comment-page-1

4、http://www.cmsky.com/shadowsocks-manyuser-sspanel/comment-page-1/#comment-4251

网上找到的

3.0多用户客户端安装教程

http://www.mamicode.com/info-detail-1207901.html

http://www.mamicode.com/info-detail-1083151.html

http://bubuko.com/infodetail-1411842.html


Docker版本shadowsocks多用户ss-panel控制台

http://www.w2bc.com/article/101528

http://www.bubuko.com/infodetail-1417508.html